SQL Exception when saving entrys

Jacob's Avatar

Jacob

06 Feb, 2017 09:36 AM

I get multiple SQL exceptions when trying to save new entry's used in structure.
We ran on EE 3.5.1 and structure 4.0.3. When i tried to modify a entry i get a 'SQLSTATE[42000]: Syntax error or access violation: 1064'. Then i tried to delete the page and recreate a new entry but it gives me the attached exception, this counts for all new entry's in structure. How can we fix this, thanks in advance.

  1. 1 Posted by Jacob on 06 Feb, 2017 09:37 AM

    Jacob's Avatar

    The exception from the attached file in plain text:

    SQLSTATE[22003]: Numeric value out of range: 1690 BIGINT UNSIGNED value is out of range in '((`dev_educatief`.`node`.`rgt` - `dev_educatief`.`node`.`lft`) - 1)':
    SELECT node.*, (COUNT(parent.lft) - 2) AS depth, if((node.rgt - node.lft) = 1,1,0) AS isLeaf, ((node.rgt - node.lft - 1) DIV 2) AS numChildren FROM exp_structure AS node INNER JOIN exp_structure AS parent ON node.lft BETWEEN parent.lft AND parent.rgt WHERE node.site_id = 1 GROUP BY node.lft LIMIT 1

  2. Support Staff 2 Posted by Support on 06 Feb, 2017 07:49 PM

    Support's Avatar

    Hi Jacob, how many records do you currently have in your exp_structure table and what webserver stack are you running on (apache, nginx, php-fpm, php as FastCGI, etc)?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2017-02-06_at_10.27.12.png 261 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac