Deleting entries causing Validation issues - not able to resolve without breaking more stuff

Justin Alei's Avatar

Justin Alei

06 Jun, 2017 07:35 PM

Hi guys,
I'm having a weird issue after upgrading a site to EE3, then deleting a bunch of entries which were old events. This was brought to my attention when the client tried to re-add one of the events I deleted, but because the Structure URL was identical to what it previously was, there's some kind of routing issue because the event isn't being recognized and the {exp:channel:entries} tag returns nothing.

So going to Structure > Validation, I'm getting a whole bunch of errors where the actual entries are removed and the Structure routing is missing, but the EE URL Routing is still there (see attached Structure Validation.jpg). But picking one out (eg '5-keys-to-increasing-your-influence-on-social-media'), this is not in the DB anywhere when I search and it's not in the files anywhere either (confirmed by grepping for it). Also clicking on the Entry ID link (eg 247 in my screenshot) confirms the entry doesn't exist with the "Error: There are no entries matching the criteria you selected." message.

Plus the numbers showing in the Validation screen don't seem to match up - I have a total of 976 entries, 689 of those are in channels managed by Structure, yet only 653 of those are showing in the Validation screen

Then, when I try to resolve the validation issues by clicking the 'Using Structure' button, which I believe is the correct method I should be using, it changes the Structure URL on a whole bunch of entries causing even more issues - I get entire sections of the site that disappear from the navigation, but show perfectly fine in the backend Structure overview page and after doing this, the Validation screen shows there's a whole bunch of duplicates (ie, the pages that went missing from the navigation)...

So it's a mess and I'm not sure how to resolve this. My questions are:

1. Where is the Structure Validation page getting these entries from because I can't find them in the DB or in the file system anywhere

2. How do I resolve this without breaking the entries I do still have, but aren't showing for whatever reason in the Validation screen - ie, the 36 or so missing (getting this figure from the 689 structure-managed entries I actually have minus the 653 reported in the Validation screen)

3. What is supposed to happen when an entry is deleted via the main Entry listing screen (eg Edit > Events)?

Have you guys ever seen this before?

Thanks,
Justin

  1. 1 Posted by Justin Alei on 06 Jun, 2017 07:36 PM

    Justin Alei's Avatar

    Sorry, the file upload got lost - attached again

  2. 2 Posted by Justin Alei on 07 Jun, 2017 06:09 PM

    Justin Alei's Avatar

    Quick update on this issue - I rolled back and redid the upgrade but deleted all of the events *before* assigning the entries to be Structure Listings... and doing it in this order did not result in these miss-matches.

    However, I did still get this when deleting a channel (which in turn deletes the entries in the channel) but in this case, the whole channel is gone so not being able to add entries with the old URL isn't going to keep me from being able to launch...

    But the questions still stand - so any input would be appreciated.

    Thanks,
    Justin

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac