Structure URL deletes itself after saving

russ's Avatar

russ

21 Mar, 2018 09:07 PM

Hi,

After a relatively long uneventful period using Structure (3.3.14.5 in EE 2.9), this morning our site has suddenly started having an issue where the Structure URL of new pages are no longer saving. The entry is then visible in the Structure interface and even appears in listing pages on the website after publishing, but the URL is not added to the link and therefore goes nowhere.

Upon reopening the entry, the Structure URL field is blank. No changes have been made recently that would affect our CMS like this, and I tried making a new page in a completely different part of the site, where the same issue persists. I have tried activating debug mode and clicking the 'fix it' button, but all that does is delete the new orphaned pages, while the issue still occurs.

I was told someone accidentally put a slash in the URL field when they first tried to publish the page, but Structure typically filters that out anyway from my recollection.

Any thoughts on what might be happening here? This is pretty urgent for us.

  1. 1 Posted by russ on 21 Mar, 2018 10:32 PM

    russ's Avatar

    Apologies,

    It looks like this was a SQL database issue on our end. Feel free to delete this issue!

  2. Support Staff 2 Posted by Support on 22 Mar, 2018 11:25 AM

    Support's Avatar

    Sure thing! As a side note, Structure 4.x has a lot of extra validation and protections against corruption as well as a History feature so in the event of a corruption or inadvertent change to your Structure tree, you can roll back to a previous version. We recommend all Structure users upgrade to the 4.x branch.

  3. Support closed this discussion on 22 Mar, 2018 11:25 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac